[ejabberd] Re: not working on Linux alpha

Jiann-Ming Su sujiannming at gmail.com
Wed Dec 29 23:29:03 MSK 2004


On Wed, 29 Dec 2004 17:30:51 +0000, Brian Campbell <bacam at z273.org.uk> wrote:
> 
> I'm running ejabberd successfully using Debian on an Ultra1, using the
> version of erlang in testing (9.2.2-6).  There were two problems though:
> You can't have the erlang documentation for a different version
> installed (erlang can't find some of the libraries if the version 10
> documentation is installed), and you must rebuild the ejabberd package
> (because the one in unstable is built for erlang 10).
> 

Okay, I did as you suggested... I have erlang and erlang-common
9.2.2-6 from the debian repositories installed.  I tried building
ejabberd 0.7.5-6 using "apt-get --compile source ejabberd".  This
didn't work at first because it barfs on the erlang Build-Depends and
Depends in the debian/control file.  It didn't like "erlang (>=1:10). 
I changed that to (>=9.2.2).  I then ran "dpkg-buildpackage -b -uc"
and it successfully built a deb package for me.  I was able to install
it, and it appears ejabberd is working properly on my alpha now.

-- 
Jiann-Ming Su
"I have to decide between two equally frightening options. 
 If I wanted to do that, I'd vote." --Duckman


More information about the ejabberd mailing list