[ejabberd] Re: Ejabberd & LDAP

Martin Galoneas galoneas at mail.com
Thu Jul 22 14:52:10 MSD 2004


> Leif Johansson wrote:
>
> >  Perhaps my problem is link to this bug found by a jabberd2 user :
> > http://www.jabberstudio.org/projects/jabberd2/bugs/view.php?id=3320
> > 
> > I'm still investigating, but i'm quite new to erlang and ldap .. so every help is welcome :)
> > 
> > thx
> > MG
> 
> Perhaps. We need to make sure that ejabberd is closing connections
> quickly enough. You might be running out of connections on your ldap
> server (what does "netstat -a | grep ldap | wc -l" get you on your
> ldap server?)
> 
> 	Cheers Leif
>

Before starting Ejabberd "netstat -a | grep ldap" returns :
tcp        0      0 *:ldap                  *:*                     LISTEN

After launching Ejabberd, i get this return :
tcp        0      0 *:ldap                  *:*                     LISTEN
tcp        0      0 localhost:33460         localhost:ldap          ESTABLISHED
tcp        0      0 localhost:ldap          localhost:33460         ESTABLISHED

If I connect 3 accounts at the same time, it returns :
tcp        0      0 *:ldap                  *:*                     LISTEN
tcp        0      0 localhost:33460         localhost:ldap          TIME_WAIT

Few minutes later, "netstat -a | grep ldap" returns again :
tcp        0      0 *:ldap                  *:*                     LISTEN

I noticed that after the 'crash', the connected users are still able to add contact to their rosters, to talk to each others, but no one can join the server until i restart it.

thx for your help
Martin
-- 
___________________________________________________________
Sign-up for Ads Free at Mail.com
http://promo.mail.com/adsfreejump.htm



More information about the ejabberd mailing list