[ejabberd] Compiling ejabberd

Ian Stokes-Rees i.stokes-rees1 at physics.ox.ac.uk
Mon May 10 18:23:59 MSD 2004



Marshall Rose wrote:
>>I am trying to install ejabberd.  I have erlang R9C-0 installed. 
>>ejabberd keeps telling me that it can't find erl or erlc:
>>
>>checking for erlc... no
>>checking for erl... no
>>
>>however these are accessible in:
>>
>>/usr/local/bin/
>>/usr/local/lib/erlang/bin
>>
>>I have tried
>>
>>./configure --with-erlang=/usr/local/bin
>>./configure --with-erlang=/usr/local/lib/erlang/bin
>>
>>and other various combinations of path, however they all result in the 
>>same error.
> 
> 
> 	./configure --with-erlang=/usr/local
> 
> /mtr

No love:

[root at lxgate03 src]# ./configure --with-erlang=/usr/local
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking whether make sets ${MAKE}... yes
checking for erlc... no
checking for erl... no
configure: error: erlang not found

[root at lxgate03 src]# ls /usr/local/bin/erl*
/usr/local/bin/erl  /usr/local/bin/erlang  /usr/local/bin/erlc

-- 
Ian Stokes-Rees                 i.stokes-rees1 at physics.ox.ac.uk
Particle Physics, Oxford        http://www-pnp.physics.ox.ac.uk/~stokes


More information about the ejabberd mailing list