[ejabberd] How to get AIM gateway working?

dragon_sphere at vdsworld.com dragon_sphere at vdsworld.com
Tue Oct 12 21:39:49 MSD 2004


> <snip>
>>   I took a look at the page you mentioned.  I had already read that
>> page.
>> This link does not seem to be specific to EJabberd nor is it setup
>> instructions for making the AIM transport work under EJabberd.  Again I
>> do not know how to program in Erlang so I would not be able to convert
>> the AIM Transport from C to Erlang??
>
> You need Jabberd 1.4.x for the old AIM-transport:
> 1) compile Jabberd
> 2) copy the resulting .so files to the libs-dir (I think xdb_file.so
> suffices)
> 3) configure the AIM-transport to run as a separate service (this is
> always
> prefered): see example config file included with AIM-transport
> 4) include the xdb- and logs-sections like described in the ejabberd Guide
> (and also in the example config file of AIM-transport I think).
> 5) add a line for AIM-transport in the listen section of your ejabberd
> config.
> 6) triple-check if the password of the transport config and ejabberd
> config
> match.
> 7) optional: create a nice init-script for AIM-transport
>
> You also can consider to use the experimental pyAIM-t which do not depends
> on
> Jabberd1.4.x at all but uses Twisted-python and which supports xml:lang
> for
> user interaction.
>

Well if I was using Linux or Unix then I guess it would be that easy but
since I am using Windows XP it's not this easy.  Trying to get MinGW
working under Windows is alot of work and will take time to get all the
parts in place.  Plus MinGW has changed since last time I used it which
was about 3-4 years ago so I am not up to speed on what the heck MSys is
and how to use it.  Lots of reading ahead;-)  I wish the source files were
preped for Lcc or LccWin32 since that is what I am familiar with and
currently using.  Anyway if nothing else it would be nice if the source
files could be used with BloodShed Dev-C++ then this would be no problem
at all. So maybe I will take a look at pyAIM-t and see if I can get that
working for me but I have not used Python in almost 8 years so doubt it
will happen:-)  In the meantime I had an issue making SSL connections with
ejabberd so I have temp. switched back to jabberd 1.4.3 since there is
already a Windows compiled version of this as well.  It seems that the
Windows version of ejabberd would see the certificate and send it to the
client with no problem but when it trys to start the SSL stream the client
just sits there on the clock.  I tried the PSI client when this happened. 
I also tried Exodus 0.9.0.0 for windows and I don't think it would connect
at all.  I cannot remember the exact error message it gave.  Also it seems
that Exodus uses TLS so I am not sure how to configure it with ejabberd.

Thanks,
JKinsey (AKA DragonSphere)




More information about the ejabberd mailing list