[ejabberd] old incarnation

Bartosz 'briest' Stepien briest.ejab at qbanet.com
Sun Oct 31 16:13:11 MSK 2004


Hello,

I'm trying to setup a two-node ejabberd cluster, using ejabberd 0.7.5 
(erlang 9C-2 compiled from sources with ssl patch, Debian Sarge). Both 
nodes see each other as running, mnesia replication went (as far as I 
can see) OK also, I was able to log on and perform 4th step of cluster 
setup with tkabber. Then I restarted both nodes (only for welcome 
message changes in configuration files), tried to log on...

First logon after ejabberd start (or restart) completes, subsequent ones 
wait forever. Even after succesful logon, nothing more can be done, 
everything I send to server (presence, discovery, privacy lists...) 
results only in following error on the server side:

=ERROR REPORT==== 2004-10-31 13:33:08 ===
Discarding message 
(1,3){route,{jid,"login","server.com",[],"login","server.com",[]},{jid,"login","server.com","resource","login","server.com","resource"},{xmlelement,"iq",[{"id","43"},{"type","error"}],[{xmlelement,"query",[{"xmlns","jabber:iq:privacy"}],[{xmlelement,"active",[{"name","i-am-visible-list"}],[]}]},{xmlelement,"error",[{"code","404"},{"type","cancel"}],[{xmlelement,"item-not-found",[{"xmlns","urn:ietf:params:xml:ns:xmpp-stanzas"}],[]}]}]}}to 
a process in an old incarnation of this node

Everything I send is discarded with the same error ('Discarding message 
(..) to a process in an old incarnation...').

I have no idea of possible reason, nor was I able to google anything 
about it; do not even know, what kind of information can be important... 
ejabberd runs as an unprivileged user (named jabber), that owns mnesia 
and log directories, everything else is owned by root.

One more thing that may be important: as I work remotely on both nodes, 
there were several network outages when ejabberd was running 
interactively (started without -detached option), and, of course, it 
died when connection went down. Maybe old lock/run files?

I'd be grateful for some advice, thanks in advance

briest


More information about the ejabberd mailing list