[ejabberd] Re: ejabberdctl strange behavior

Frank Niedermann fbn at thelogic.org
Sun Sep 26 18:40:43 MSD 2004


Hi Sergei,

Sergei Golovan <sgolovan at nm.ru> wrote:
> On Sun, Sep 26, 2004 at 12:57:54PM +0000, Frank Niedermann wrote:
>> I have a strange behavior of ejabberdctl
> In ejabberdctl the use of -name is hardcoded, so if you run ejabberd with
> -sname option then you have to change -name for -sname in ejabberdctl and run
> it as ejabberdctl ejabberd at iws1 <option>

I run ejabberd with -sname option and this is the line from ejabberdctl:
exec erl -noinput -sname ejabberdctl -s ejabberd_ctl -extra $@
so I think that should match ...

But it is still not working for me because of not running with fully
qualified hostnames:

iws1:/var/lib/ejabberd/ebin# erl -noinput -sname ejabberdctl -s
  ejabberd_ctl -extra ejabberd at iws1.de status
Can't get node 'ejabberd at iws1.de' status: nodedown
=ERROR REPORT==== 26-Sep-2004::16:38:20 ===
** System NOT running to use fully qualified hostnames **
** Hostname iws1.de is illegal **


If I use ejabberd at iws1 instead of ejabberd at iws1.de I get something
different:
iws1:/var/lib/ejabberd/ebin# erl -noinput -sname ejabberdctl -s
  ejabberd_ctl -extra ejabberd at iws1 status
Can't get node ejabberd at iws1 status: nodedown


Thanks for your help!

Regards,
  Frank
-- 
  Mail: fbn at thelogic.org
  XMPP: fbn at charente.de



More information about the ejabberd mailing list