[ejabberd] LDAP AUTH seems to be broken in ejabberd 1.0.0

Enrique Vadillo evadillo at millicom.net.pe
Thu Dec 22 20:30:13 MSK 2005


I've been reading all the messages in here and the mailing list
and it looks like anyone who has tried to authenticate using
ejabberd's ldap auth has failed. Only fbv has succeded BUT
using an external script to authenticate his ldap users:

http://ejabberd.jabber.ru/node/88

I installed ejabberd 1.0.0 and have succeded to authenticate
using the internal auth, piece of cake really but when it came
to authenticating using ldap it never worked, something very
strange to me is the fact that whenever i switch to ldap auth
ejabberd even stops responding on ports 5222 and 5280 and if i
go back to internal auth, it works like a charm again.

BTW I know about ldap, so i pretty much know what i'm doing..
i'd like to know it anyone:

- has succeded to authenticate using ldap and would be
  willing to tip us
- or has an external script that is willing to share, because
  what is a complete mistery is how the args are received and
  the exit codes (some part of C or perl source might help)

Hope someone cares to read this and feels like helping.

I'm using JWchat & exodus as clients but they're not to blame..

Enrique-


More information about the ejabberd mailing list