[ejabberd] Installation of Erlang with OpenSSL on Solaris

María Isabel López Sánchez-Huete marisa at ugr.es
Wed Mar 9 15:35:28 MSK 2005


	I tried to configure Erlang R9C-2, but I apprehend I obtain the almost 
the same result:
*********************************************************************
**********************  APPLICATIONS DISABLED  **********************
*********************************************************************
crypto         : No usable OpenSSL found
ssl            : No usable OpenSSL found
*********************************************************************

	In this case, neither exists the --with-openssl option in the configure 
program.

	I don´t see the way. Can anyone give me a peep of light?

	Thanks.

María Isabel López Sánchez-Huete wrote:

>     There's not any  option for ssl to configure Erland. I tried anyware 
> and I obtain:
> configure: error: --whith-openssl=/usr/local/ssl: invalid option; use 
> --help to show usage
> 
>     Any more idea?
> 
> P.D. I'll now try with the version of Erlang you indicated.
> 
> Badlop wrote:
> 
>> María Isabel López Sánchez-Huete escribió:
>>
>>> I'm now installing Erlang R10B3 on Solaris 8 (Sparc) with 
>>> openssl-0.9.7e to include the crypto application.
>>
>>
>>  >
>>
>>> The openssl was installed perfectly as a software package in my system.
>>>
>>> Running ./configure however - still tells me that OpenSSL is not 
>>> found in /usr/local/ssl (which is where it is installed). Exactly the 
>>> error was:
>>> *********************************************************************
>>> **********************  APPLICATIONS DISABLED  **********************
>>> *********************************************************************
>>> crypto         : No usable OpenSSL found
>>> ssh            : No usable OpenSSL found
>>> ssl            : No usable OpenSSL found
>>> *********************************************************************
>>
>>
>>
>> Does this help?
>> ./configure --with-openssl=PREFIX   prefix where OPENSSL is installed
>>
>> Maybe it's a problem in latest R10B3+Solaris (it worked for me on 
>> Debian sid). Try R9C-2.
>> _______________________________________________
>> ejabberd mailing list
>> ejabberd at jabber.ru
>> http://lists.jabber.ru/mailman/listinfo/ejabberd
>>
> 

-- 



More information about the ejabberd mailing list