[ejabberd] LDAP Problems...

tty at SAFe-mail.net tty at SAFe-mail.net
Wed Mar 16 19:56:29 MSK 2005


Your AUTH line indicates that you are using encrypted logins with LDAP. Ejabberd does not support this option. You have 2 choices: 

a) use plaintext login on your client (in which case I strongly suggest turning c2s SSL support on) or 

b) patch ejabberd. 

If you are interested in the patch let me know. 

Regards

totem 

-------- Original Message --------
From: Karsten Jahn <KarstensListen at gmx.de>
Apparently from: ejabberd-bounces at jabber.ru
To: ejabberd at jabber.ru
Subject: [ejabberd] LDAP Problems...
Date: Wed, 16 Mar 2005 14:56:17 +0100

> Hi there!
> 
> I do have seroius problems connecting to LDAP. Everytime I try, I get an 
> error (Unauthorized). EJabberD shows this:
>    =INFO REPORT==== 16-Mar-2005::14:46:50 ===
>    I(<0.258.0>:ejabberd_listener:89): (#Port<0.363>) Accepted connection
>    {{10,32,5,22},2720} -> {{10,32,5,18},5222}
>    AUTH:
>    {"karsten.jahn",[],"f253f0fa6a1cc58084c1a89eb45682fde7084001","Work"}
> 
>    =INFO REPORT==== 16-Mar-2005::14:46:50 ===
>    I(<0.315.0>:ejabberd_c2s:322): (#Port<0.363>) Failed legacy
>    authentification for karsten.jahn at foo.de/Work
> 
> My ejabberd.cfg looks like this:
>    % For LDAP authentification use these lines instead of above one:
>    {auth_method, ldap}.
>    {ldap_servers, ["server.foo.de"]}.    % List of LDAP servers
>    {ldap_uidattr, "CN"}.        % LDAP attribute that holds user ID
>    {ldap_base, "dc=foo,dc=de"}. % Base of LDAP directory
> 
>    % Host name:
>    {host, "foo.de"}.
> 
> What may be wrong?
> Thanks for every little hint.
> Karsten
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd






More information about the ejabberd mailing list