[ejabberd] Can't make ejabberd...

Travis Bell travisbell at mac.com
Tue Oct 11 08:27:56 MSD 2005


Hey guys,

I have got every pre-requisite installed correctly (as far as I can  
see) but when I go to "make" ejabberd it spits out the following error;


lasher:/Users/admin/Desktop/ejabberd-0.9.8/src root# make
gcc -Wall -g -O2 -I/usr/local/lib/erlang/usr/include  \
                 expat_erl.c \
                 -lexpat  \
                 -L/usr/local/lib/erlang/lib/erl_interface-3.5.4/lib - 
lerl_interface -lei -I/usr/local/lib/erlang/lib/erl_interface-3.5.4/ 
include -I/usr/local/lib/erlang/usr/include \
                 -o expat_erl.so -fpic -shared
gcc: unrecognized option `-shared'
cc1: warning: -fpic is not supported; -fPIC assumed
expat_erl.c: In function `ei_x_encode_string_len_fixed':
expat_erl.c:81: warning: implicit declaration of function `x_fix_buff'
ld: Undefined symbols:
_main
_driver_alloc
_driver_alloc_binary
_driver_free
_set_port_control_flags
make: *** [expat_erl.so] Error 1


This is on a G5 Xserve with OS X 10.3. I have checked my PATH vars  
and they seem to look good.

Can anyone help me out here? I am at somewhat of a loss!

-- 
Travis Bell



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jabber.ru/pipermail/ejabberd/attachments/20051010/1762ebe7/attachment.html


More information about the ejabberd mailing list