[ejabberd] jabberlang: function not exported: xml_stream:start

Joel Reymont joelr1 at gmail.com
Fri Apr 28 18:23:49 MSD 2006


Folks,

What am I doing wrong here?

	Thanks, Joel

1> {ok, G} = xmpp:start('talk.google.com').
{ok,<0.32.0>}
2> xmpp:set_login_information(G, "xxx at google.com", {password, "xxx"}).
ok
3> xmpp:connect(G).

=INFO REPORT==== 28-Apr-2006::15:21:11 ===
I(<0.32.0>:xmpp:263): Connected to talk.google.com:5222

** exited: {undef,[{xml_stream,start,[<0.32.0>]},
                    {xmpp,ready_to_connect,3},
                    {gen_fsm,handle_msg,7},
                    {proc_lib,init_p,5}]} **

=ERROR REPORT==== 28-Apr-2006::15:21:11 ===
** State machine <0.32.0> terminating
** Last message in was {'$gen_sync_event',{<0.30.0>,#Ref<0.0.0.37>}, 
{connect}}
** When State == ready_to_connect
**      Data  == {state,undefined,
                         undefined,
                         undefined,
                         [],
                         xmpp_callbacks,
                         "xxx at google.com",
                         {password,"xxxx"},
                         "Jabberlang",
                         'talk.google.com',
                         5222,
                         "0",
                         "normal",
                         [],
                         "Jabberlang",
                         "0.3",
                         true}
** Reason for termination =
** {'function not exported',[{xml_stream,start,[<0.32.0>]},
                              {xmpp,ready_to_connect,3},
                              {gen_fsm,handle_msg,7},
                              {proc_lib,init_p,5}]}

--
http://wagerlabs.com/







More information about the ejabberd mailing list