[ejabberd] Trying to get ejabberd 1.0 + native pgsql

Peter Millard pgmillard at gmail.com
Mon Feb 6 20:43:11 MSK 2006


This definitely helped... I needed to copy src/ejabberd_odbc* to my
ebin directory, and my server at least started up :)  Shouldn't make
install copy these files over?? Seems like a deficiency in the
Makefile.

Now, I'm unable to do in-band registration, or create accounts using
the ejabberdctl util. When I do inband reg, I get a CONFLICT error for
some reason:

SENT: <iq id="jcl_5" type="set"><query
xmlns="jabber:iq:register"><username>pgmillard</username><password>test</password></query></iq>

RECV: <iq from='dustpuppy' id='jcl_5' type='error'><query
xmlns='jabber:iq:register'><username>pgmillard</username><password>test</password></query><error
code='409' type='cancel'><conflict
xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/></error></iq>

When I try to use the ejabberdctl util, it drops an erl_crash.dump
file onto my disk. This file is huge.. I can post relevant bits if you
want, just point me to the right place in the dump file.

pgm.

On 2/6/06, Mickael Remond <mickael.remond at process-one.net> wrote:
> you probably do not have the ejabberd_odbc_sup.beam. You need to
> specifically ask for compilation.
>
> Everything is included in the installer (latest version), but if you are
> compiling it by yourself, you need to specifically ask for the ODBC
> elements: The ODBC directory contains everything for external database
> and need to be enabled even to use the native driver:
>
> ./configure --enable-odbc
>
> Please, let us know if it helps,


More information about the ejabberd mailing list