[ejabberd] ejabberd lost user accounts

Heiner Wolf wolf at bluehands.de
Fri Mar 31 19:45:00 MSD 2006


Hi,

I am testing ejabberd for LLuna. I got a strange behaviour:

I created test accounts. After enabling TLS all accounts are lost. I
can not login to the web admin interface, because the admin user seems
also to be affected. I created a new user and it works, I create a new
admin user and web admin works again. I repeated adding the admin user
and ejaggerdctl tells me that the admin user is already registerd. So
my guess is that the admin user was really lost.

I am not erlang wizard enough to look into the database. Maybe they
are still there but something else changed.

This is really serious. I was going to deploy ejabberd for the LLuna
project and for external LLuna customers. But if there is a remote
possibility that users can be erased by commenting in 2 wrong lines in
ejabberd.cfg, then I have a problem.

To be more specific, here is what I did:
1. Removed %% from these 2 lines
{5222, ejabberd_c2s,     [{access, c2s}, {shaper, c2s_shaper},
starttls, {certfile,
"/home/BLUEHANDS/wolf/Projekte/JabberVP/ejabberd-1.0.0/conf/server.pem"}]},

I did not get the fact that I have to comment out:
{5222, ejabberd_c2s,     [{access, c2s},...

2. So, both were in the config file. The server did not start
correctly. ejabberdctl reported a successful start, but NO ports were
listening (netstat).

3. I stopped with ejabberdctl, worked.

4. I commented out the non TLS listen by adding %% to 2 lines:
%%{5222, ejabberd_c2s,     [{access, c2s},
%%{shaper, c2s_shaper}]},

5. Started server. Ports are listening. web admin interface is
available, but I can not log in to the web admin. None of my test user
accounts can authenticate.

6. PANIC. Stop server. Reverse changes in ejabberd.ctl. Start server.
None of the accounts work.

7. I added a new user, which works and authenticated correctly. Added
a new admin user, worked. As a test, re-added admin user: "admin
already registered"

I suspect that my initial insane config harmed something. Is there a
remote possibility, that the server destroys the database, if it fails
to start correctly due to "listen: address already in use". There is
nothing suspicious in the log.

Can anyone explain what happened?

Regards
hw
--
Dr. Heiner Wolf
bluehands GmbH & Co.mmunication KG
http://www.bluehands.de/people/hw
+49 (0721) 16108 75

--
Jabber enabled Virtual Presence on the Web: www.lluna.de
Open Source Future History: www.galactic-developments.de


More information about the ejabberd mailing list