[ejabberd] (no subject)

Randy Bush randy at psg.com
Wed May 24 19:44:03 MSD 2006


from a side conversation

    > At Wed, 24 May 2006 08:21:03 -0700, Randy Bush wrote:
    > > 
    > > (gdb) back
    > > #0  0x2820348b in pthread_atfork () from /lib/libpthread.so.2
    > > #1  0x281fa55e in pthread_kill () from /lib/libpthread.so.2
    > > #2  0x28186460 in ?? ()
    > 
    > sigh.
    > 
    > gut reaction (probably unjustified, given how long it's been since
    > last i tried something like this):
    > 
    >   bullwinkle:	hey rocky, watch me fork after starting pthreads!
    >   rocky:	again?  but that trick never works!
    >   bullwinkle:	this time for sure!
    > 
    > but that doesn't help you solve your problem, so i'll shut up now.
    > 
    In retrospect, of course, it was obviously a thread problem.  But that's
    hindsight.

    When NetBSD built its own, unique (scheduler activation-based) thread
    system, lots of applications didn't work.  They were flat-out buggy, but
    they (sort of) worked on Linux with its libraries and nothing else
    mattered (or was even noticed).  I simply can't run linphone, even though
    I've heard it's better than kphone, because of a thread-related locking
    issue -- NetBSD detects it and Linux doesn't.  But heaven help you if you
    complain -- "your OS is broken; my app runs fine", saith the penguinista.

    So -- I have no idea how to fix the problem, but I'd bet there's a small,
    probably-correct-per-semantic-definition change to the thread library that
    has upset ejabberd.

i am trying with threading commented out

    # grep CONFIGURE_ARGS /usr/ports/lang/erlang/Makefile
    #CONFIGURE_ARGS+=       --enable-threads --enable-kernel-poll
    CONFIGURE_ARGS+=        --enable-hipe

randy



More information about the ejabberd mailing list