[ejabberd] epoll - 11B-r1 modified patch

Heiner Wolf wolf at bluehands.de
Tue Sep 5 19:28:12 MSD 2006


Hi,

I installed used the linux all-in-one installer to install ejabberd-1.1.1.
my "erl +K true" says:
  kernel-poll not supported; "K" parameter ignored
Amazingly it knows what +K means, but id does not like it.

Being an erlang agnostic, I can not parse all it tells me. erl claims it is:
  Erlang (BEAM) emulator version 5.4.12

Does anyone know what OTP version I have?
Is this modified patch for my erlang version?
I don't even dare to ask how to apply the patch to my all-in-one
installation.

hw

On 9/5/06, Daniel Bartlett <dan at f-box.org> wrote:
>
> Hi there,
> I have recently modified the patch so it cleanly applies to the recent
> 11B-r1 release of Erlang.
>
> I have not had a chance to fully test, but I believe the only changes
> have been the allocation of memory and some minor changes to the
> configure.in file.
>
> The only test that has been run is a 10000 users Tsung test on ejabberd,
> and the load looked a lot better :)
>
> I hope this patch is correct!
>
> Cheers,
> Daniel.
>
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jabber.ru/pipermail/ejabberd/attachments/20060905/10705a84/attachment.htm


More information about the ejabberd mailing list