[ejabberd] Preparing for version 1.1.2

Badlop badlop at gmail.com
Sun Sep 24 13:33:40 MSD 2006


2006/9/24, Mickael Remond <mickael.remond at process-one.net>:
> This bug exists in 1.1.1 but should normally have been fixed in 1.1.2:

I've just tried again with 1.1.2, and it seems to be fixed :)

Since I tested several versions (1.0.0, 1.1.1, 1.1.2, svn), maybe I
forgot to reduce the timeout on 1.1.2.

BTW, the timeout is default to 5 minutes. JWChat has configurable poll
intervals of 1 second up to 30. Is there any point in having a timeout
of 300 seconds? Shouldn't 35 seconds, or 60, be more appropiate?


Curiosity: This is the log when closing a JWChat client on
ejabberd+Yaws 1.64. Even with that Yaws ERROR, the session is closed
correctly after the timeout:

=INFO REPORT==== 24-Sep-2006::11:19:09 ===
I(<0.294.0>:ejabberd_listener:90): (#Port<0.853>) Accepted connection
{{127,0,0,1},46122} -> {{127,0,0,1},5280}

=INFO REPORT==== 24-Sep-2006::11:19:09 ===
I(<0.288.0>:ejabberd_http:76): started: {gen_tcp,#Port<0.853>}

=INFO REPORT==== 24-Sep-2006::11:19:09 ===
I(<0.294.0>:ejabberd_listener:90): (#Port<0.858>) Accepted connection
{{127,0,0,1},40460} -> {{127,0,0,1},5280}

=INFO REPORT==== 24-Sep-2006::11:19:09 ===
I(<0.727.0>:ejabberd_http:175): (#Port<0.853>) http query: 'POST' /http-poll/


=INFO REPORT==== 24-Sep-2006::11:19:09 ===
I(<0.288.0>:ejabberd_http:76): started: {gen_tcp,#Port<0.858>}

=INFO REPORT==== 24-Sep-2006::11:19:09 ===
I(<0.730.0>:ejabberd_http:175): (#Port<0.858>) http query: 'POST' /http-poll/


=ERROR REPORT==== 24-Sep-2006::11:19:09 ===
Yaws process died: {{error,ebadf},
                    [{yaws,gen_tcp_send,2},
                     {yaws_revproxy,ploop,3},
                     {yaws_server,aloop,3},
                     {yaws_server,acceptor0,2},
                     {proc_lib,init_p,5}]}

=INFO REPORT==== 24-Sep-2006::11:19:22 ===
I(<0.702.0>:ejabberd_c2s:1161): ({http_poll,<0.701.0>}) Close session
for user at localhost/jwchat



--


More information about the ejabberd mailing list