[ejabberd] Installer on Debian 4.0 Etch 64bit.

Badlop badlop at gmail.com
Sat Aug 4 05:44:46 MSD 2007


Florian had some DNS troubles today. Anyway, we chatted in the
chatroom, and he asked me to put this info:

2007/8/3, Christophe Romain <cromain at process-one.net>:
> what gives the command 'uname -m' on your bash ?
> i guess x86_64 ?

$ uname -a
Linux flosoft.biz 2.6.18-4-amd64 #1 SMP Fri May 4 00:37:33 UTC 2007
x86_64 GNU/Linux

>
> keep the directory installer created
> then edit the arch function of ejabberdctl script to force your
> 'uname -m' use x86 (example if x86_64)
> x86_64) echo x86 ;;
>
> then apply the post install
> ejabberdctl register admin yourhost password
>
> then use ejabberd as usual.

He found problems with crypto stuff:
http://paste.florianjensen.com/?81

I  proposed him to compile ejabberd from sources. But he likes to have
a working ejabberdctl. I proposed him to copy his new 64bit' *.so
files to the 32bit binary installed dir. He tried and failed with the
same error report. Maybe the files were not copied to the right dir.

I suggested him to try the Debian ejabberd package: it's 64bit real,
and has a nice ejabberdctl. He refused because Debian has only 1.1.2
packages, not the newer 1.1.3. So he thinks ejabberd package in Debian
is not maintained anymore, is completely dead and ejabberd 2.0.0 will
never be released in Debian.

I told him that Debian people didn't like ejabberd 1.1.3. That they
still used the version number "1.1.2", even if the code may be exactly
1.1.3. That maybe they didn't consider as problems how much
misconceptions and confusion that mismatched numbering could generate.
I told him that Debian people keep ejabberd perfectly updated, and I
finally convinced him to try ejabberd Debian package.

In a matter of minutes he got ejabberd running.

Anyway, there are 64bit Linux distros out there that do not have nice
ejabberd packages like Debian and other distros have. So, I think some
administrators will like a 64bit Linux binary installer.

----


=PROGRESS REPORT==== 4-Aug-2007::02:23:11 ===
         application: mnesia
          started_at: ejabberd at localhost

=PROGRESS REPORT==== 4-Aug-2007::02:23:26 ===
          supervisor: {local,crypto_sup}
             started: [{pid,<0.194.0>},
                       {name,crypto_server},
                       {mfa,{crypto_server,start_link,[]}},
                       {restart_type,permanent},
                       {shutdown,2000},
                       {child_type,worker}]

=CRASH REPORT==== 4-Aug-2007::02:23:26 ===
  crasher:
    pid: <0.194.0>
    registered_name: crypto_server
    error_info: {port_died,normal}
    initial_call: {gen,init_it,
                      [gen_server,
                       <0.193.0>,
                       <0.193.0>,
                       {local,crypto_server},
                       crypto_server,
                       [],
                       []]}
    ancestors: [crypto_sup,<0.192.0>]
    messages: []
    links: [<0.193.0>]
    dictionary: []
    trap_exit: true
    status: running
    heap_size: 233
    stack_size: 21
    reductions: 675
  neighbours:

=SUPERVISOR REPORT==== 4-Aug-2007::02:23:26 ===
     Supervisor: {local,crypto_sup}
     Context:    child_terminated
     Reason:     {port_died,normal}
     Offender:   [{pid,<0.194.0>},
                  {name,crypto_server},
                  {mfa,{crypto_server,start_link,[]}},
                  {restart_type,permanent},
                  {shutdown,2000},
                  {child_type,worker}]


=PROGRESS REPORT==== 4-Aug-2007::02:23:26 ===
         application: crypto
          started_at: ejabberd at localhost

=PROGRESS REPORT==== 4-Aug-2007::02:23:26 ===
          supervisor: {local,crypto_sup}
             started: [{pid,<0.195.0>},
                       {name,crypto_server},
                       {mfa,{crypto_server,start_link,[]}},
                       {restart_type,permanent},
                       {shutdown,2000},
                       {child_type,worker}]


More information about the ejabberd mailing list