[ejabberd] new ejabberd-1.1.3 linux installer

Badlop badlop at gmail.com
Sun Aug 5 16:07:17 MSD 2007


2007/8/1, Christophe Romain <cromain at process-one.net>:
> here is a newly generated installer for ejabberd-1.1.3 that should be
> binary compatible with 1.1.2
> https://support.process-one.net/secure/attachment/11409/
> ejabberd_std-1.1.3-linux-x86-installer.bin
>
> so it should work on linux distro that was previously not supported.
> any comments are welcome.

Hi Christophe,

I got a response from Leonid Evdokimov (aka Darkk). He told me to post
this both in the ejabberd mailing list and in Jira bug tracker,
because he isn't yet registered in any of them:

1. I tested installer from
https://support.process-one.net/secure/attachment/11409/ejabberd_std-1.1.3-linux-x86-installer.bin
 Its md5sum is d4e1607666b10c6276ed75df84cd8823

2. crypto seems to work perfectly now :)
It didn't work with the old ejabberd 1.1.3 binary Linux x86 installer.
Now it says:
$ cd /dev/shm
$ ejabberd-1.1.3/bin/erl
Erlang (BEAM) emulator version 5.4.12 [source] [hipe] [threads:0]

Eshell V5.4.12  (abort with ^G)
1> crypto:start().
ok
2>

3. This may generate problems, but it's probably unlikely: ./bin/beam
uses "external" (system) libncurses.so.5 and libz.so.1

4. Maybe ODBC has some issues now, but I've not tested it. shell-spell
made me think so:
$ cd /dev/shm/ejabberd-1.1.3
$ find . -perm +111 -type f | while read f; do ldd $f | { grep 'not
found' && echo ^^^$f; } ; done
        libodbc.so.1 => not found
^^^./lib/odbc-2.0.6/priv/linux-x86/bin/odbcserver


More information about the ejabberd mailing list