[ejabberd] ejabberd crashes after editing config

Badlop badlop at gmail.com
Sat Dec 8 21:46:13 MSK 2007


2007/12/7, Jens Lederer <jens.lederer at mni.fh-giessen.de>:
> i tried to add another service to my ejabberd. i removed the setting
> again after my ejabberd dind't run anymore. but ejabberd still isn't
> running correctly. that's the errormessage as provided by
> /var/log/ejabberd/sasl.log
>
>
> =CRASH REPORT==== 7-Dec-2007::10:13:07 ===
>   crasher:
>     pid: <0.40.0>
>     registered_name: []
>     error_info: {bad_return,{{ejabberd_app,start,[normal,[]]},
>
> {'EXIT',{{badmatch,{aborted,{no_exists,config}}},
>                                        [{ejabberd_config,set_opts,1},
>                                         {ejabberd_app,start,2},
>
> i don't understand waht this means. is there anybody who can explain it
> to me?

This same error message is explained here:
http://www.ejabberd.im/node/602


> i thought there's an error in my ejabberd.cfg, but it doesn't seem so.

The word 'config' in the error message refers to the database table
'config', not to the ejabberd configuration file.

When you have a syntax in your configuration file, ejabberd shows a
different error message.


Could it be that you changed the computer hostname? Or the Erlang node
name (this is indicated with the parameters -sname or -name?

If you do not have important information in the database (several
users...), the easiest solution is to simply delete the spool files
and they will be regenerated.


More information about the ejabberd mailing list