[ejabberd] Ejabberd last svn - crashes with web_admin

Badlop badlop at gmail.com
Sat Dec 8 22:11:11 MSK 2007


2007/12/7, jcbeylot <jcbeylot at gmail.com>:
> i installed  ejabberd-1.1.4 ( with linux installer ) on a server ( Suse SLES
> 9.0 ) with 2 processors and memory of 2 Go,  everything is ok.
>
> today , i install ejabberd  last svn on this server .
> i use erlang  version 5.5.5  compiled with enable-kernel-poll and
> enable-smp-support
> Every time i use web_admin to see virtual servers, ejabberd crashes.

Do you mean when visiting a URL like this?
  http://localhost:5280/admin/vhosts/

I tried SVN r1053 with a similar setup without problem, with/without
smp and kernel poll. I use Debian packages.
  Erlang (BEAM) emulator version 5.5.5 [source] [smp:2]
[async-threads:0] [hipe] [kernel-poll:true]

Could it be that you mixed binary files from old ejabberd 1.1.x with
the new ones?

Another reason could be the recent massive changes in SVN to remove
compilation warnings. You could try a slightly older SVN revision, for
example 1000.

If you still get this problem, then the problem may be in older
changes. Inspecting the source code, SVN Blame points me to another
change in SVN r767:
https://forge.process-one.net/changelog/ejabberd?cs=767
You could try with an older revision to see if this changeset is
problematic for you. For example try r766.


> using top , i see  that beam uses  99%  of CPU then  i get this error
> message :
> Crash dump was written to: /test/var/log/ejabberd/erl
> _crash.dump.20071207-162609
> eheap_alloc: Cannot allocate 583848200 bytes of memory (of type "heap").
> /test/sbin/ejabberdctl: line 142:  2250 Aborted                 erl $SNAME
> $ERLANG_NODE $ERLANG_OPTS -pa $EJABBERD_EBIN -mnesia dir "\"$EJABBERD_DB\""
> -s ejabberd
> ).
> i tested with and without kernel pool  or smp  using options in
> ejabberdctl.cfg.   Every time ejabberd crashes.
>
> is it a known  problem ?

I wasn't aware of it. Please report the results of your tests. If all
fails, we can debug what part of that page generates the problem.


More information about the ejabberd mailing list