[ejabberd] eJabberd Clustering

Florian Jensen admin at flosoft.biz
Sun Jun 10 17:16:11 MSD 2007


Hi,

I'm still trying to cluster my two eJabberd Servers.

The cookies match, but I get a pang. A normal System Ping works.

On the first server I found this in the logs.

=ERROR REPORT==== 2007-06-09 16:42:23 === ** Connection attempt from
disallowed node ejabberd at ds4044 **

I can't find any solution to this problem.

Florian Jensen

On Fri, 8 Jun 2007 22:17:40 +0200, Florian Jensen <admin at flosoft.biz>
wrote:
> Hey,
> 
> I am stuck setting up a cluster between two ejabberd 1.1.3 servers. No
> spools need to be imported.
> 
> I followed this guide here:
> http://www.process-one.net/docs/ejabberd/guide_en.html#htoc74 (10.2)
> 
> I am stuck at step 2.
> 
> When I type mnesia:info(). it gives me:
> 
> jabber at ds4044:~/ejabberd-1.1.3$ erl -sname ejabberd     -mnesia
> extra_db_nodes "['ejabberd at ds3811']"     -s mnesia
> Erlang (BEAM) emulator version 5.5.2 [source] [async-threads:0]
> [kernel-poll:false]
> 
> Eshell V5.5.2  (abort with ^G)
> (ejabberd at ds4044)1> mnesia:info().
> ---> Processes holding locks <---
> ---> Processes waiting for locks <---
> ---> Participant transactions <---
> ---> Coordinator transactions <---
> ---> Uncertain transactions <---
> ---> Active tables <---
> schema         : with 1        records occupying 388      words of mem
> ===> System info in version "4.3.3", debug level = none <===
> opt_disc. Directory "/home/jabber/ejabberd-1.1.3/Mnesia.ejabberd at ds4044"
> is
> NOT used.
> use fallback at restart = false
> running db nodes   = [ejabberd at ds4044]
> stopped db nodes   = [ejabberd at ds3811]
> master node tables = []
> remote             = []
> ram_copies         = [schema]
> disc_copies        = []
> disc_only_copies   = []
> [{ejabberd at ds4044,ram_copies}] = [schema]
> 2 transactions committed, 0 aborted, 0 restarted, 0 logged to disc
> 0 held locks, 0 in queue; 0 local transactions, 0 remote
> 0 transactions waits for other nodes: []
> ok
> (ejabberd at ds4044)2>
> 
> 
> The problem here is: the foreign host is under stopped db nodes??
> 
> Anyone have any clue how to set up the server cluster correctly?
> 
> Contact me via Jabber: admin at im.flosoft.biz
> 
> Greets,
> 
> Florian Jensen
> --
> Flosoft.biz / CEK Media Service
> CEK Media Service
> Seestr. 8
> 73773 Aichwald
> Germany
> 
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
-- 
Flosoft.biz / CEK Media Service
CEK Media Service
Seestr. 8
73773 Aichwald
Germany



More information about the ejabberd mailing list