[ejabberd] Strange problem with HTTP stuff on NetBSD

Jonathan Schleifer js at h3c.de
Sun Jun 17 15:48:19 MSD 2007


Hi!

I'm experiencing strange behaviour with the HTTP stuff in ejabberd
(namely admin and poll) on my server running on NetBSD.

The config looks like this:
  {5280, ejabberd_httpd,        [http_poll, web_admin]},
So this should be ok.

Now to the problem:
Whenever I try to connect to port 5280, the connection is accepted and
gets INSTANTLY closed. I also used a packet sniffer which showed
exactly the same. Here's an example:

$ telnet 127.0.0.1 5280
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.

As you can see, the connection gets instantly closed after being
established.

At first, I thought that some ejabberd process might crash as soon as
the connection is established, but it seems that this isn't the case.
When I start ejabberd without -noshell -detach, I see no error message
at all when I connect to port 5280. It's only written that the
connection was accepted and nothing more.
The ejabberd.log and sasl.log don't show anything about this either.

Is there anybody else out there running ejabberd on NetBSD who could
try using the HTTP stuff?

The versions I use are:
NetBSD: 4.0_BETA
OTP: R11B-5 (also tried with R11B-0)
ejabberd: SVN + native PgSQL module (also tried with 1.1.3 + PgSQL)

TIA,

-- 
Jonathan
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 618 bytes
Desc: not available
Url : http://lists.jabber.ru/pipermail/ejabberd/attachments/20070617/de90ab77/attachment.pgp 


More information about the ejabberd mailing list