[ejabberd] crash on start

Zbyszek Żółkiewski zbyszek at toliman.pl
Sat May 5 02:46:45 MSD 2007


You have reason in first two lines - just read them (config file not found )
this is probable reason...


On 5/5/07, Nicolas <valombre at gmail.com> wrote:
>
> Hi,
>
> I get problems starting ejabberd daemon, it crashes everytime I try to
> start it, with this message :
>
> {error_logger,{{2007,5,5},{0,26,34}},std_error,"File operation error:
> > eacces. Target: /etc/ejabberd/inetrc. Function: get_file. Process:
> > kernel_sup."}
> > {error_logger,{{2007,5,5},{0,26,34}},"inet_config: file ~s not
> > found~n",["/etc/ejabberd/inetrc"]}
> > {error_logger,{{2007,5,5},{0,26,35}},"Protocol: ~p: register error:
> > ~p~n",["inet_tcp",{{badmatch,{error,duplicate_name}},[{inet_tcp_dist,listen,1},{net_kernel,start_protos,4},{net_kernel,start_protos,3},{net_kernel,init_node,2},{net_kernel,init,1},{gen_server,init_it,6},{proc_lib,init_p,5}]}]}
> >
> > {error_logger,{{2007,5,5},{0,26,35}},crash_report,[[{pid,<0.21.0
> > >},{registered_name,net_kernel},{error_info,{error,badarg}},{initial_call,{gen,init_it,[gen_server,<
> > 0.18.0>,<0.18.0>,{local,net_kernel},net_kernel,{ejabberd,shortnames,15000},[]]}},{ancestors,[net_sup,kernel_sup,<
> > 0.8.0>]},{messages,[]},{links,[#Port<0.8>,<0.18.0
> > >]},{dictionary,[{longnames,false}]},{trap_exit,true},{status,running},{heap_size,233},{stack_size,21},{reductions,452}],[]]}
> > {error_logger,{{2007,5,5},{0,26,35}},supervisor_report,[{supervisor,{local,net_sup}},{errorContext,start_error},{reason,{'EXIT',nodistribution}},{offender,[{pid,undefined},{name,net_kernel},{mfa,{net_kernel,start_link,[[ejabberd,shortnames]]}},{restart_type,permanent},{shutdown,2000},{child_type,worker}]}]}
> >
> > {error_logger,{{2007,5,5},{0,26,35}},supervisor_report,[{supervisor,{local,kernel_sup}},{errorContext,start_error},{reason,shutdown},{offender,[{pid,undefined},{name,net_sup},{mfa,{erl_distribution,start_link,[]}},{restart_type,permanent},{shutdown,infinity},{child_type,supervisor}]}]}
> >
> > {error_logger,{{2007,5,5},{0,26,35}},crash_report,[[{pid,<0.7.0
> > >},{registered_name,[]},{error_info,{shutdown,{kernel,start,[normal,[]]}}},{initial_call,{application_master,init,[<
> > 0.5.0>,<0.6.0>,{appl_data,kernel,[application_controller,erl_reply,auth,boot_server,code_server,disk_log_server,disk_log_sup,erl_prim_loader,error_logger,file_server_2,fixtable_server,global_group,global_name_server,heart,init,kernel_config,kernel_sup,net_kernel,net_sup,rex,user,os_server,ddll_server,erl_epmd,inet_db,pg2],undefined,{kernel,[]},[application,application_controller,application_master,application_starter,auth,code,code_aux,packages,code_server,dist_util,erl_boot_server,erl_distribution,erl_prim_loader,erl_reply,erlang,error_handler,error_logger,file,file_server,file_io_server,prim_file,global,global_group,global_search,group,heart,hipe_unified_loader,inet6_tcp,inet6_tcp_dist,inet6_udp,inet_config,inet_hosts,inet_gethost_native,inet_tcp_dist,init,kernel,kernel_config,net,net_adm,net_kernel,os,ram_file,rpc,user,user_drv,user_sup,disk_log,disk_log_1,disk_log_server,disk_log_sup,dist_ac,erl_ddll,erl_epmd,erts_debug,gen_tcp,gen_udp,gen_sctp,prim_inet,inet,inet_db,inet_dns,inet_parse,inet_res,inet_tcp,inet_udp,inet_sctp,pg2,seq_trace,wrap_log_reader,zlib,otp_ring0],[],infinity,infinity},normal]}},{ancestors,[<
> > 0.6.0>]},{messages,[{'EXIT',<0.8.0>,normal}]},{links,[<0.6.0>,<0.5.0
> > >]},{dictionary,[]},{trap_exit,true},{status,running},{heap_size,987},{stack_size,21},{reductions,2063}],[]]}
> > {error_logger,{{2007,5,5},{0,26,35}},std_info,[{application,kernel},{exited,{shutdown,{kernel,start,[normal,[]]}}},{type,permanent}]}
> >
> > {"Kernel pid
> > terminated",application_controller,"{application_start_failure,kernel,{shutdown,{kernel,start,[normal,[]]}}}"}
> >
> > Crash dump was written to: erl_crash.dump
> > Kernel pid terminated (application_controller)
> > ({application_start_failure,kernel,{shutdown,{kernel,start,[normal,[]]}}})
>
>
> (can't understand anything ^^`)
> I can send you the erl_crash.dump if need.
> It does it even after a complete reinstall of the ejabberd package (using
> apt-get)
>
> I'm running Debian Lenny & amd64 architecture
>
> Any idea ?
>
> Thanks in advance
> --
> Nicolas
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>


-- 
pozdrawiam,
Zbyszek Żółkiewski
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jabber.ru/pipermail/ejabberd/attachments/20070505/1d697a4a/attachment.htm 


More information about the ejabberd mailing list