[ejabberd] SOLVED: ejabberd crashing on startup

Paul Johnson baloo at ursine.ca
Thu May 17 17:50:03 MSD 2007


Sergei Golovan wrote in Article
<f60b7eb60705170615m64fd56adt2738e810d536e819 at mail.gmail.com> posted to
gmane.network.jabber.ejabberd:

> On 5/17/07, Paul Johnson <baloo at ursine.ca> wrote:
>> I'm a little bit confused as to why I can't get ejabberd started all the
>> sudden.  I don't recall changing anything leading up to this.  Only
>> output
>> I can get from starting ejabberd is in sasl.log.  Here's the meaty part:
>>
>> =PROGRESS REPORT==== 17-May-2007::04:16:01 ===
>>          application: ssl
>>           started_at: 'ejabberd at ursa-major'
>>
>> =CRASH REPORT==== 17-May-2007::04:16:02 ===
>>   crasher:
>>     pid: <0.36.0>
>>     registered_name: []
>>     error_info: {bad_return,{{ejabberd_app,start,[normal,[]]},
>>                               {'EXIT',{{badmatch,{aborted
>> {no_exists,config}}},
> 
> A common case for this error message is changing hostname. Mnesia
> database ties its schema to the hostname, so if it's to be changed you
> has to migrate database (see http://ejabberd.jabber.ru/migrate-host).

Wow, reminds me of one of my friends using pom(6) to tack on part of a
filename on a Windows share...only to have the file not save because the
name was too long depending literally on the phase of moon.  Kind of
curious that something like a /etc/hosts setting would be that thrown
off...

Oddly enough, the hostname didn't even change, I moved the hostname from the
localhost line to the line identifying the IP on eth0...moved it back and
it worked.

-- 
Paul Johnson
Email and IM (XMPP & Google Talk): baloo at ursine.ca




More information about the ejabberd mailing list