[ejabberd] Problem with native postgresql driver and web admin

Teemu Harju teemu.harju at gmail.com
Thu Oct 11 10:50:29 MSD 2007


Hi,

I seem to have a strange problem with the postgresql and web admin. I'm
using ejabberd 1.1.4 and the native postgresql driver from jungerl package.
Then problem is that I cannot login to the web admin page. I always get "401
Unauthorized" when trying to login with correct username at domain and password
combination. I tried with internal authentication using mnesia and it worked
just fine. So it would seem that there is nothing wrong with my
configuration. The database connection to postgresql seems to work since I'm
able to add users using ejabberdctl when postgresql is configured.

The config for postgres is like this...

{auth_method, odbc}.
{odbc_server, {pgsql, "localhost", "ejabberd", "ejabberd", "ejabberd"}}.

If I comment that out and switch to...

%{auth_method, internal}.

... then everything works.

Logs don't seem to show anything special.

Regards,

- Teemu

-- 
Teemu Harju

email/jabber: teemu.harju at gmail.com
blog: http://www.teemuharju.net

~~ "A computer is like air conditioning: it becomes useless when you open
windows." ~~
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.jabber.ru/pipermail/ejabberd/attachments/20071011/c5cb46f1/attachment.html 


More information about the ejabberd mailing list