[ejabberd] Error with spooled data

Davidson Rodrigues Paulo davidsonpaulo at gmail.com
Sat Sep 29 00:06:32 MSD 2007


Hi all,

I'm using eJabberd 1.1.3 on a Fedora Core 6 with Linux kernel 2.6.19.
It's running pretty good since I've installed and configured it,
without interruptions or any kind of problems. eJabberd it's really a
wonderful software.

This afternoon I've modified it's configuration in an attempt to use
Active Directory authentication instead of OpenLDAP, which is being
used by now. I did the following:

# cd /etc/ejabberd
# cp -a ejabberd.cfg ejabberd.cfg.bkp
# vim ejabberd.cfg
# service ejabberd stop
# service ejabber start

After this, I was unable to authenticate myself, so I undid the changes:

# mv ejabberd.cfg.bkp ejabberd.cfg
# service ejabberd stop
# service ejabberd start

So, for my surprise, I still was unable to authenticate. I have
restarted eJabberd many times and at least I have restarted the entire
virtual machine (a Xen guest), but it not worked.

So, I did this:

# service ejabberd stop
# cd /var/lib
# tar cp ejabberd | gzip -9 > ejabberd.tgz
# rm -rf ejabberd/*
# service ejabberd start

The problem with the authentication so was solved. But I've lost all
information about shared rosters and other changes. So I did:

# service ejabberd stop
# cd /var/lib
# rm -rf ejabberd
# tar zxpf ejabber.tgz
# service ejabber start

And the problem with authentication returned.

As you could see, the problem is with spooled data under
/var/lib/ejabberd/spool. But I don't know how do fix this without
losing all my configuration.

Do you see some way to solve that problem?

Thanks,

Davidson Paulo


More information about the ejabberd mailing list