[ejabberd] google s2s issues and weird sasl log error

Peter Saint-Andre stpeter at stpeter.im
Sat Feb 16 07:52:39 MSK 2008


Jesse Thompson wrote:
> Our server cluster is running otherwise fine, and all s2s communication
> appears to work with one exception.  For some reason, I can't get
> presence packets to go to/from Gmail and Google Apps users.  This has
> been happening for over a week.

Yes, that seems to be endemic of late. I have not seen good debug
information about this. I do know that the connection from jabber.org to
Google Talk has not had many problems.

> I can send and receive messages to/from Google without issue.  It's just
> the presence packets that get hung up.

Yes, that is quite odd. From the protocol perspective (dialback etc.)
that doesn't make any sense.

> Presence packets go through to Google just fine when using our test
> cluster.
> 
> Netstat shows that the server is connected to Google, both incoming and
> outgoing.

That is consistent with your report that only presence is not getting
through.

> The only thing I see is this error in the sasl log around 10 times/day.
>  I can't tell what it means.  Any ideas?  Does it explain the s2s problem?

I don't think so, but I'm not an expert at reading ejabberd logs. :)

/psa

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 7338 bytes
Desc: S/MIME Cryptographic Signature
Url : http://lists.jabber.ru/pipermail/ejabberd/attachments/20080215/31bbb88c/attachment.bin 


More information about the ejabberd mailing list