[ejabberd] Unexpected auth error on pubsub (2.0.1)

Kevin Crosbie kcrosbie at ravenpack.com
Sun Jul 6 22:29:05 MSD 2008


Stefan,

I ran into a similar problem.   I think you need to create the root node 
first:

/home/galactica.local/fluts/

Hope this helps.

Stefan Arentz wrote:
> I'm getting an unexpected error when I try to create a pubsub node.  
> I'm sending this as user fluts at galactica.local, which can succesfully  
> login.
>
> This is what I send:
>
> <iq type="set" from="fluts at galactica.local"  
> to="pubsub.galactica.local" id="create1">
>     <pubsub xmlns="http://jabber.org/protocol/pubsub">
>        <create node="/home/galactica.local/fluts/xxx"/>
>        <configure/>
>     </pubsub>
> </iq>
>
> This is what I receive:
>
> <iq from='pubsub.galactica.local' to='fluts at galactica.local/Galactica'  
> type='error' id='create1'>
>     <pubsub xmlns='http://jabber.org/protocol/pubsub'>
>        <create node='/home/galactica.local/fluts/xxx'/>
>        <configure/>
>     </pubsub>
>     <error code='403' type='auth'>
>        <forbidden xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/>
>     </error>
> </iq>
>
> My ejabberd.cfg is completely default. It has the 'all allowed'  
> condfiguration for pubsub:
>
> %% Everybody can create pubsub nodes
> {access, pubsub_createnode, [{allow, all}]}.
>
> {mod_pubsub, [
>     {access_createnode, pubsub_createnode},
>     {plugins, ["default", "pep"]}
> ]},
>
> I'm not sure what I am doing wrong. THis is basically the same XML as  
> listed on
>
>   http://www.ejabberd.im/mod_pubsub-usage
>
> Does anyone understand what is going on here?
>
>   S.
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>   



More information about the ejabberd mailing list