[ejabberd] Trouble with apache/jwchat/http-bind

Badlop badlop at gmail.com
Mon Jun 9 21:19:54 MSD 2008


Hi, I answer your email in a modified order:

> I have the ejabberd and two test-clients:
>
> - Kopete
> - An apache web server with jwchat connecting to http-bind and
>  http-poll.
>
> Although both clients see each other and go into a chat, they actually
> can't talk, i.e. the kopete (regular 5222) can send to the jwchat,
> but jwchat can't send text to kopete. Although I see traffic on Port
> 5280, ejabberd seems to silently discard.

You should also try to chat between two regular desktop clients,
to be sure the problem is in the http-poll part.


> BTW: where would I find a description of the http-bind and http-poll
> methods and which one is the preferable one?

Preferable: http-bind. Search for BOSH in the XEP names:
http://www.xmpp.org/extensions/

http-poll: this protocol is deprecated:
http://www.xmpp.org/extensions/xep-0025.html


On Tue, Jun 3, 2008 at 4:23 PM, Hadmut Danisch <hadmut at danisch.de> wrote:
> I have some trouble with a ejabberd (1.1.4 from ubuntu 8.04)

You could try also with ejabberd 2.0.1.

If you already have 1.1.4 running in production, you can test 2.0.1 in
other machine to verify if that helps or not.

Note that ejabberd 2.0.x includes an embedded mini web server, so you
don't need an external server if you don't want. Check the related
tutorial:
  Install JWChat with ejabberd's HTTP-Bind and file server
  http://www.ejabberd.im/jwchat-localserver


> is there a method to get detailed debugging output from ejabberd?

Yes, set in ejabberd.cfg loglevel to 5. But probably it will be too
much verbose.
And that option is available since ejabberd 2.0.0


---


More information about the ejabberd mailing list