[ejabberd] removing nodes from cluster

Zbyszek Żółkiewski zbyszek at toliman.pl
Fri Sep 26 19:25:03 MSD 2008


i got the same problem way time ago (and i think others as well), here is my
blogpost about that:
http://www.planeta.toliman.pl/2007/02/mclean.html

it is in polish, so just copy, edit and compile the program, you must
shutdown all nodes, then on every node
run program :
mclean:clean(['node at name.pl']).

it will clean given node, remember to edit patch to schema.DAT file on every
node!


On Fri, Sep 26, 2008 at 17:06, Stephan Maihöfer <sma at turtle-entertainment.de
> wrote:

>  hi,
>
> i have a few "inactive nodes" that i would like to remove so i can
> start over with new ones. i tried the remove-node command
> of ejabebrctl with mod_ctlextra and even tried to delete the
> schema of the nodes manually. first yields no result at all, second
> gives me this:
>
> (ejabberd at ejabberd1)4 <ejabberd at ejabberd1%294>>
> mnesia:del_table_copy(schema, 'ejabberd at ejabber2'<%27ejabberd at ejabber2%27>
> ).
> {aborted,{not_active,"All replicas on diskfull nodes are not active yet",
>                      schema,
>                      ['ejabberd at ejabberd2']}}
>
> in the web-admin all the nodes still are being shown as
> "inactive" and i can't create another node by that name from
> scratch.
>
> any hints on this?
>
> thanks,
> stephan
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>


-- 
pozdrawiam,
Zbyszek Żółkiewski
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20080926/21b625c5/attachment.htm>


More information about the ejabberd mailing list