[ejabberd] trouble clustering with ejabberd 2.0.2_2 and mySQL

Tom tom.valdes at gmail.com
Tue Sep 30 20:19:30 MSD 2008


Is Clustering with ejabberd something that is not widely done?
I've spent the last few days reading and trying everything but I am 
still stuck.
Is someone willing to get on Instant Messaging and help me out?
thanks,
tom

btw:
I've gone back to using mnesia to try to get clustering working and I'm 
having trouble with that as well.

Tom wrote:
> I have 2 ejabberd machines set up  (testim and testim02).  Each server 
> points to its own mySQL database and I can connect to each one without 
> issue. (when not clustered)
>
> The trouble comes when I attempt to cluster them.
> If I start the first server (testim) with the following command:
> ./erl -sname ejabberd -mnesia extra_db_nodes "['ejabberd at testim02 
> <mailto:ejabberd at testim02>']" -s mnesia -ejabberd config 
> "/opt/ejabberd-2.0.2_2/conf/ejabberd.cfg"
>
> and the second server (testim02) with the following:
> ./erl -sname ejabberd -mnesia extra_db_nodes "['ejabberd at testim 
> <mailto:ejabberd at testim>']" -s mnesia -ejabberd config 
> "/opt/ejabberd-2.0.2_2/conf/ejabberd.cfg"
>
> I get successful pongs:
>
> (ejabberd at testim)1> net_adm:ping('ejabberd at testim02').
> pong
>
> (ejabberd at testim02)6> net_adm:ping('ejabberd at testim').
> pong
>
>
> But I am not able to login to either one using my jabber client.
>
> thanks,
> tom
>
> btw: this is on Linux (if it matters)



More information about the ejabberd mailing list