[ejabberd] ejabberd_communication_with_Opensips

JayaPrakash jp.manchu at gmail.com
Wed Apr 1 11:17:33 MSD 2009


Hi All,
I am trying to communicate Opensips server with ejabberd server.(both are
located at the same machine)
Opensips is configured to connect to ejabberd in component mode at port
5347.
ejabberd is configuered to accept connections from outer servers as shown
below.
*****************************************************************************************************************************
{listen,
 [
%% Component Connection
  {5347, ejabberd_service, [
                           {access, all},
                           {shaper_rule, fast},
                           {ip, {127, 0, 0, 1}},
                           {hosts, "localhost.dev.ongobiz.com", [{password,
"secret"}]}
                           ]},
%dev.ongobiz.com is the host name of ejabberd_server.
---------------------------------
{{s2s_host, "localhost"}, allow}.
---------------------------------
{s2s_use_starttls, true}.
{s2s_certfile, "/etc/ejabberd/ejabberd.pem"}.
{s2s_default_policy, allow}.
---------------------------------
*******************************************************************************************************************************
Now Opensips is trying to connect to ejabberd. However, it is not connected.
ejabberd log file is keep on generating the following error.

=INFO REPORT==== 2009-04-01 12:26:16 ===
I(<0.272.0>:ejabberd_listener:112) : (#Port<0.132787>) Accepted connection
{{127,0,0,1},36511} -> {{127,0,0,1},5347}

=INFO REPORT==== 2009-04-01 12:26:16 ===
I(<0.1428.4>:ejabberd_service:115) :
({socket_state,gen_tcp,#Port<0.132787>,<0.1427.4>}) External service
connected

=INFO REPORT==== 2009-04-01 12:26:16 ===
I(<0.1428.4>:ejabberd_service:352) : terminated: {{invalid_domain,108},
                                                  [{ejabberd_router,
                                                    register_route,2},
                                                   {ejabberd_service,

'-wait_for_handshake/2-fun-0-',
                                                    1},
                                                   {lists,foreach,2},
                                                   {ejabberd_service,
                                                    wait_for_handshake,2},
                                                   {gen_fsm,handle_msg,7},
                                                   {proc_lib,init_p,5}]}

=ERROR REPORT==== 2009-04-01 12:26:16 ===
** State machine <0.1428.4> terminating
** Last event in was {xmlstreamelement,
                         {xmlelement,"handshake",[],
                             [{xmlcdata,

<<"f8252dbc2163057f83924dc0a8f6f10512f6b669">>}]}}
** When State == wait_for_handshake
**      Data  == {state,{socket_state,gen_tcp,#Port<0.132787>,<0.1427.4>},
                        ejabberd_socket,"280805813",
                        "localhost.dev.ongobiz.com","secret",all,true}
** Reason for termination =
** {{invalid_domain,108},
    [{ejabberd_router,register_route,2},
     {ejabberd_service,'-wait_for_handshake/2-fun-0-',1},
     {lists,foreach,2},
     {ejabberd_service,wait_for_handshake,2},
     {gen_fsm,handle_msg,7},
     {proc_lib,init_p,5}]}

Will you please suggest me how to solve this issue.

Thanks
JayaPrakash
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20090401/7140b0e1/attachment.htm>


More information about the ejabberd mailing list