[ejabberd] standalone ejabbered and s2s connections

Jan Koum jan.koum at gmail.com
Thu Aug 20 21:56:31 MSD 2009


hi,

i was looking through the server logs and noticed something strange:

=INFO REPORT==== 2009-08-19 14:50:24 ===
I(<0.9240.0>:ejabberd_s2s:368) : New s2s connection started <0.9241.0>

=INFO REPORT==== 2009-08-19 14:50:24 ===
I(<0.9241.0>:ejabberd_s2s_out:1135) : Trying to open s2s connection:
s.xxx.net -> proxy.jabber.org

=INFO REPORT==== 2009-08-19 14:50:24 ===
I(<0.9241.0>:ejabberd_s2s_out:230) : s2s connection: s.xxx.net ->
proxy.jabber.org (remote server not found)

=INFO REPORT==== 2009-08-19 14:50:26 ===
I(<0.9241.0>:ejabberd_s2s_out:831) : Reconnect delay expired: Will now retry
to connect to proxy.jabber.org when needed.

my server is a stand-alone jabber server.  so why is is trying to connect to
proxy.jabber.org?  any ideas?  my config is:

{loglevel, 4}.
{hosts, ["s.xxx.net"]}.
{listen, [  {5222, ejabberd_c2s, [
            {certfile, "/home/xxx/xmpp/x.pem"}, starttls,
            {access, c2s},
            {shaper, c2s_shaper},
            {max_stanza_size, 65536}  ] ]}.
{auth_method, internal}.
{shaper, normal, {maxrate, 1000}}.
{shaper, fast, {maxrate, 50000}}.
{acl, admin, {user, "admin", "s.xxx.net"}}.
{acl, local, {user_regexp, ""}}.
{access, max_user_sessions, [{1, all}]}.
{access, local, [{allow, local}]}.
{access, c2s, [{deny, blocked},  {allow, all}]}.
{access, c2s_shaper, [{none, admin},  {normal, all}]}.
{access, s2s_shaper, [{fast, all}]}.
{access, announce, [{allow, admin}]}.
{access, configure, [{allow, admin}]}.
{access, muc_admin, [{allow, admin}]}.
{access, muc, [{allow, all}]}.
{access, register, [{deny, all}]}.
{access, pubsub_createnode, [{allow, all}]}.
{language, "en"}.
{modules, ....  ]}.


-- yan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20090820/9e64036e/attachment.html>


More information about the ejabberd mailing list