[ejabberd] Gloox does not connect to ejabberd.

Badlop badlop at gmail.com
Tue Aug 25 14:48:54 MSD 2009


2009/8/24 Rommel S Trindade <rommel.trindade at wannet.com.br>:
> I'm testing gloox version 0.9.9.7.
> But i'm having problems to connect to ejabberd 2.0.5 server.
> The logs from gloox are written below.
> I'd appreciate any help about this issue.
>
> Aug  8 22:13:19 localhost Gloox: ::handleLog: level0 area:16384 <?xml
> version='1.0' ?><stream:stream to='xxxx.xxxxxxx.com.br'
> xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams'
> xml:lang='en' version='1.0'>

> Aug  8 22:13:19 localhost Gloox: ::handleLog: level0 area:8192
> <stream:stream xmlns='jabber:client'
> xmlns:stream='http://etherx.jabber.org/streams' id='2185483648'
> from='localhost' xml:lang='en'/>


Strange: the example XML you provided does not produce the same
ejabberd response for me.

$ sudo ejabberdctl start

$ sudo ejabberdctl status
Node ejabberd at localhost is started. Status: started
ejabberd is running

$ sudo tcpflow -i lo -ec tcp port 5222
tcpflow[8798]: listening on lo

127.000.000.001.60468-127.000.000.001.05222:
<?xml version='1.0' ?><stream:stream to='localhost' xmlns='jabber:client'
 xmlns:stream='http://etherx.jabber.org/streams'  xml:lang='en' version='1.0'>

127.000.000.001.05222-127.000.000.001.60468:
<?xml version='1.0'?><stream:stream xmlns='jabber:client'
 xmlns:stream='http://etherx.jabber.org/streams' id='2221284335'
from='localhost' version='1.0' xml:lang='en'>

127.000.000.001.05222-127.000.000.001.60468:
<stream:features><starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>
<mechanisms xmlns='urn:ietf:params:xml:ns:xmpp-sasl'>
<mechanism>PLAIN</mechanism>
<mechanism>DIGEST-MD5</mechanism>
</mechanisms>
<register xmlns='http://jabber.org/features/iq-register'/>
</stream:features>



---
Badlop
ProcessOne


More information about the ejabberd mailing list