[ejabberd] mod_pubsub_odbc error report

Terry Xie kitlycol at gmail.com
Fri Dec 4 20:11:27 MSK 2009


i was get the error message when starting ejabberd .

here is the ejabberd.log:

=INFO REPORT==== 2009-12-04 16:28:11 ===
I(<0.397.0>:ejabberd_c2s:703) :
({socket_state,tls,{tlssock,#Port<0.456>,#Port<0.460>},<0.396.0>}) Accepted
authentication for terry by ejabberd_auth_odbc

=INFO REPORT==== 2009-12-04 16:28:11 ===
I(<0.397.0>:ejabberd_c2s:817) :
({socket_state,tls,{tlssock,#Port<0.456>,#Port<0.460>},<0.396.0>}) Opened
session for terry at gicha.com/acer-4dfc5328e1

=ERROR REPORT==== 2009-12-04 16:28:11 ===
E(<0.309.0>:mod_pubsub_odbc:3550) : transaction return internal error:
{'EXIT',

 {noproc,

{sys,

 get_status,

 [ejabberd_odbc_sup_gichacom,

500]}}}

user publishes an item also occur:

=INFO REPORT==== 2009-12-04 12:05:32 ===
I(<0.401.0>:ejabberd_c2s:703) :
({socket_state,tls,{tlssock,#Port<0.476>,#Port<0.478>},<0.400.0>}) Accepted
authentication for benimtor by ejabberd_auth_odbc

=INFO REPORT==== 2009-12-04 12:05:32 ===
I(<0.401.0>:ejabberd_c2s:817) :
({socket_state,tls,{tlssock,#Port<0.476>,#Port<0.478>},<0.400.0>}) Opened
session for benimtor at gicha.com/acer-4dfc5328e1

=ERROR REPORT==== 2009-12-04 12:05:32 ===
E(<0.318.0>:mod_pubsub_odbc:3550) : transaction return internal error:
{'EXIT',

 {noproc,

{sys,

 get_status,

 [ejabberd_odbc_sup_gichacom,

500]}}}


=ERROR REPORT==== 2009-12-04 12:06:43 ===
E(<0.318.0>:mod_pubsub_odbc:3550) : transaction return internal error:
{'EXIT',

 {noproc,

{sys,

 get_status,

 [ejabberd_odbc_sup_gichacom,

500]}}}


=ERROR REPORT==== 2009-12-04 12:07:02 ===
E(<0.318.0>:mod_pubsub_odbc:3550) : transaction return internal error:
{'EXIT',

 {noproc,

{sys,

 get_status,

 [ejabberd_odbc_sup_gichacom,

500]}}}

erlang.log have no errors .

my hosts config:

{hosts, ["gicha.com"]}.

i was use ejabberd-2.1.0 windows installer


On Sat, Dec 5, 2009 at 12:14 AM, Mark <grimm26 at gmail.com> wrote:
> Yeah, I didn't have a host setting in my mod_pubsub_odbc stanza either.
> I've added one and I'll see if it helps.
>
> --
> Mark
> "Blessed is he who finds happiness in his own foolishness, for he will
> always be happy."
>
>
> On Fri, Dec 4, 2009 at 10:05 AM, Badlop <badlop at gmail.com> wrote:
>>
>> 2009/12/4 Terry Xie <kitlycol at gmail.com>:
>> > i have the same problem on windows, but not config pubsub host issue
>> > here is my configure:
>> >
>> >  {mod_pubsub_odbc,   [ % requires mod_caps
>> >                  {access_createnode, pubsub_createnode},
>> >                  {ignore_pep_from_offline, true},
>> >                  {last_item_cache, false},
>> >                  {plugins, ["flat_odbc", "hometree_odbc", "pep_odbc",
>> > "mb_odbc"]},
>> >                  {pep_mapping, [{"urn:xmpp:microblog", "mb_odbc"}]}
>> >                 ]},
>>
>>
>> Ohh, in that case I have no idea what can be the problem.
>>
>> When do you get the error message: starting ejabberd, or when a user
>> publishes an item, or ...?
>>
>> Do you get any other error messages in ejabberd.log or erlang.log when
>> starting ejabberd?
>>
>> Can you show some examples of those error messages?
>>
>> And show the option
>> {hosts, [....]}.
>> that you have.
>>
>> Maybe something of this gives some idea where the problem is.
>>
>>
>> ---
>> Badlop
>> ProcessOne
>> _______________________________________________
>> ejabberd mailing list
>> ejabberd at jabber.ru
>> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20091205/2906be7e/attachment.html>


More information about the ejabberd mailing list