[ejabberd] error while creating admin user

Gabriel Rossetti gabriel.rossetti at arimaz.com
Mon Dec 21 19:52:10 MSK 2009


Konstantin Khomoutov wrote:
> On Mon, 21 Dec 2009 11:47:20 +0100
> Gabriel Rossetti <gabriel.rossetti at arimaz.com> wrote:
>
>   
>> ~# ejabberdctl register admin test.com 12345
>> RPC failed on the node ejabberd at srv1: {'EXIT',
>>                                        {badarg,
>>                                         [{erlang,port_control,
>>                                           [stringprep_port,1,"test.com"]},
>>                                          {stringprep,control,2},
>>                                          {jlib,nameprep,1},
>>                                          {ejabberd_auth,auth_modules,1},
>>                                          {ejabberd_auth,is_user_exists,2},
>>                                          {ejabberd_auth,try_register,3},
>>                                          {ejabberd_ctl,process,1},
>>                                          {rpc,'-handle_call/3-fun-0-',5}]}}
>>
>> The logs don't contain anything more, I am using version 2.0.1-2 and I 
>> checked to make sure ejabberd was running.
>> Does anyone know what is wrong?
>>     
>
> Looks like this one: http://www.ejabberd.im/node/3698#comment-54762
>
>   
Hmmm, strange because I have another server with "Erlang R13B01 
(erts-5.7.2) [source] [smp:2:2] [rq:2] [async-threads:0] 
[kernel-poll:false]" and ejabberd 2.0.5-1.1 and it works great, maybe 
the ubuntu team applied the patch though. I will keep on searching, 
thank you.


More information about the ejabberd mailing list