[ejabberd] S2S Problems to some Openfire servers

Nikolaus Polak nik at np-edv.at
Thu Jan 29 17:34:35 MSK 2009


Hello,

Since a few days I have problems with s2s in both directions to some servers. I'm using ejabberd 2.0.3, turned debugging on to find the problem, but I don't understand the logged things - perhaps somebody knows whats going on here (I tried to cut non-relevant things out, please ask if something needed is missing):
=INFO REPORT==== 2009-01-29 14:48:34 ===
D(<0.15525.15>:ejabberd_s2s_out:154) : started: {"linuxlovers.at",
                                                 "im.relinked.org",
                                                 {new,"10188134"}}
=INFO REPORT==== 2009-01-29 14:48:34 ===
D(<0.15525.15>:ejabberd_s2s_out:196) : open_socket: {"linuxlovers.at",
                                                     "im.relinked.org",
                                                     "10188134",false}
=INFO REPORT==== 2009-01-29 14:48:34 ===
D(<0.15525.15>:ejabberd_s2s_out:984) : srv lookup of 'im.relinked.org': [{"im.relinked.org",
                                                                          5269}]
=INFO REPORT==== 2009-01-29 14:48:34 ===
D(<0.15525.15>:ejabberd_s2s_out:246) : s2s_out: connecting to im.relinked.org:5269
=INFO REPORT==== 2009-01-29 14:48:35 ===
D(<0.15525.15>:ejabberd_s2s_out:586) : starttls: {"linuxlovers.at",
                                                  "im.relinked.org"}
=INFO REPORT==== 2009-01-29 14:48:35 ===
I(<0.15525.15>:ejabberd_s2s_out:311) : Closing s2s connection: linuxlovers.at -> im.relinked.org (close in wait_for_stream)
=INFO REPORT==== 2009-01-29 14:48:35 ===
D(<0.15525.15>:ejabberd_s2s_out:805) : terminated: {normal,wait_for_stream}

Some additional information: I'm using a certificate of xmpp.org for '*.linuxlovers.at', have c2s and s2s certificates hopefully correctly set (the connection to im.relinked.org did already work with that).
I tried also to connect to other Openfire servers, some make no problems (for example ilportalinux.it, hapi.pl), but with some like fritz-elfert.de or igniterealtime.org no s2s is possible (simple connection test with telnet works).

thanks in advance,

-- 
Nikolaus Polak - http://nplog.0nl1ne.at - xmpp:nik(at)linuxlovers.at


More information about the ejabberd mailing list