[ejabberd] S2S Problems to some Openfire servers

Nikolaus Polak nik at np-edv.at
Sat Jan 31 16:40:49 MSK 2009


----- "Nikolaus Polak" <nik at np-edv.at> wrote:

> Hello,
> 
> Since a few days I have problems with s2s in both directions to some
> servers. I'm using ejabberd 2.0.3, turned debugging on to find the
> problem, but I don't understand the logged things - perhaps somebody
> knows whats going on here (I tried to cut non-relevant things out,
> please ask if something needed is missing):

> Some additional information: I'm using a certificate of xmpp.org for
> '*.linuxlovers.at', have c2s and s2s certificates hopefully correctly
> set (the connection to im.relinked.org did already work with that).
> I tried also to connect to other Openfire servers, some make no
> problems (for example ilportalinux.it, hapi.pl), but with some like
> fritz-elfert.de or igniterealtime.org no s2s is possible (simple
> connection test with telnet works).

I did some more testing and it's still really strange to me. I found
http://www.ejabberd.im/kernel-poll#comment-53247 whith about the same
errors in the log, but this can not be my problem - I'm not using
kpoll.
My erlang version is R12B-5, without hipe. My OS is gentoo linux x86.
Also i tried a service discovery on about 50 servers found on
http://www.jabberes.org/servers/ over s2s from my server, and all
except the mentioned two are making a nice s2s connection.

-- 
Nikolaus Polak - http://nplog.0nl1ne.at - xmpp:nik(at)linuxlovers.at


More information about the ejabberd mailing list