[ejabberd] MySQL Native Driver.

Jorge Guntanis jorge at guntanis.com
Wed Jun 24 11:16:27 MSD 2009


Thanks!
So my questions arises because although in the config I have always had

{odbc_server, {mysql, ...

but in my server the mysq*l.beam where located in:
/usr/local/lib/erlang/lib/mysql-1.0/ebin/mysql.beam

which I guess makes sense. because it looks like they where compiled with
erlang instead of the ones on the your svn trunk (could this cause an
issue?).

Anyway, I have been analyzing a lot of xmpp vs mysql traffic because of the
problem I described a while ago, where I randomly do not get either the
groups or sometimes the roster (although the client gets the stanza, it's
empty), and it seems like ie. when I get no groups ejabberd does not send
mysql a query for them. But it does reply with the groups stanza. Any
insight on how this works, and why could I be getting this behaviour?

Best!

Jorge


On Tue, Jun 23, 2009 at 11:56 PM, Evgeniy Khramtsov <xramtsov at gmail.com>wrote:

> Jorge Guntanis wrote:
>
>> Hi,
>> Just wondering how can I make sure I'm using the mysql native driver
>> instead
>> of the generic odbc
>>
>
> This depends on your config file. If you have something like
> {odbc_server, {mysql, ...
> Then you definitely running MySQL.
>
> --
> Regards,
> Evgeniy Khramtsov, ProcessOne.
> xmpp:xram at jabber.ru <xmpp%3Axram at jabber.ru>.
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20090624/8ce76c2e/attachment.html>


More information about the ejabberd mailing list