[ejabberd] Error Reading Mnesia database spool files

Paul Kinlan paul.kinlan at gmail.com
Mon May 18 19:44:24 MSD 2009


Hi guys,

I have solved my problem, I changed /etc/defaults/ejabberd node name from
ERLANG_NODE=ejabberd to ERLANG_NODE=ejabberd at qiew which is the hostname of
the machine.

What I would like to understand is why this happened now. I am pretty sure I
have not changed any settings, infact the hostname is qiew (which is what it
has always been).

Paul

2009/5/18 Paul Kinlan <paul.kinlan at gmail.com>

> Hi Guys,
>
> The past couple of months this has worked perfectly, I have not had to
> alter the server even in the slightest.  Today I went to install a new
> virtual host, so I change the config by adding my host in to the
> ejabberd_cfg.  When I restarted the ejabberd server using the init scripts
> ejabberd starts but doesn not listen on any ports, if I do a sudo ejabberd
> live I get the following error.
>
> E(<0.40.0>:ejabberd_config:272) : Error reading Mnesia database spool
> files:
> The Mnesia database couldn't read the spool file for the table 'config'.
> ejabberd needs read and write access in the directory:
>    /var/lib/ejabberd
> Maybe the problem is a change in the computer hostname,
> or a change in the Erlang node name, which is currently:
>    ejabberd at localhost
> Check the ejabberd guide for details about changing the
> computer hostname or Erlang node name.
>
> I have not changed the host name, or any other configuration (that I can
> recall)
>
> Have I hosed the menesia DB?  Should I start again?  I have made the
> /var/lib/ejabberd directory globally readable and writeable, however after
> following some of the tutorials on the ejabberd.im I can find the "db/"
> folder.  The install is a basic install from apt-get on ubuntu.
>
> Many thanks in advance.
>
> Paul.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20090518/d0a79b69/attachment.htm>


More information about the ejabberd mailing list