[ejabberd] Affiliates publishing to a PEP node

Theo Cushion theo at jivatechnology.com
Wed Nov 11 15:04:35 MSK 2009


On 11 Nov 2009, at 11:57, kael wrote:

> On 11/11/2009 12:34 PM, Theo Cushion wrote:
>> Hi
>
> Hello,
>
>> However when I try to post to this node as the bot:
>> <iq type='set' from='bot at ejabberd.local' to='ejabberd.local'>
>>   <pubsub xmlns='http://jabber.org/protocol/pubsub'>
>>     <publish node='storage:foo' jid='theo.cushion at ejabberd.local'>
>>       <item>
>>         <stuff>
>> 	  bar
>>         </stuff>
>>       </item>
>>     </publish>
>>     <publish-options>
>>       <x xmlns='jabber:x:data' type='submit'>
>>         <field var='FORM_TYPE' type='hidden'>
>>           <value>http://jabber.org/protocol/pubsub#publish- 
>> options</ value>
>>         </field>
>>         <field var='pubsub#persist_items'>
>>           <value>true</value>
>>         </field>
>>         <field var='pubsub#access_model'>
>>           <value>whitelist</value>
>>         </field>
>>       </x>
>>     </publish-options>
>>   </pubsub>
>> </iq>
>> It posts to the bots pubsub node, not the jid specified in the   
>> attribute of publish
>
> The message should be posted to the JID of the delegated node (and  
> the <publish/> element has no 'jid' attribute) :
>
> <iq type='set' to='theo.cushion at ejabberd.local' from='bot at ejabberd.local 
> '>
> <pubsub xmlns='http://jabber.org/protocol/pubsub'>
>  <publish node='storage:foo'>
>   <item>
>    <stuff>bar</stuff>
>   </item>
>  </publish>
> </pubsub>
> </iq>
>

Thank you so much, that is now working a treat
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20091111/f1d6aada/attachment.html>


More information about the ejabberd mailing list