[ejabberd] node creation problem

Fabio Forno fabio.forno at gmail.com
Thu Oct 8 20:18:45 MSD 2009


On Thu, Oct 8, 2009 at 5:36 PM, Fabio Forno <fabio.forno at gmail.com> wrote:
> Today we run into a strange problem. We have always been able to
> create nodes in the pubsub service (ejabberd 2.0.5), but now for any
> new node we get the forbidden error.
>
> This is the stanza we send is this one (acls allow creation from any
> user, as for default conf):
>
> <iq to='pubsub.jabber.bluendo.com' type='set' id='H_2'>
>  <pubsub xmlns='http://jabber.org/protocol/pubsub'>
>   <create node='test01'/>
>   <configure/>
>  </pubsub>
> </iq>

I answer to myself (problem solved just after having sent the mail :()

Before everything worked since we didn't realize the before we created
the initial node /home/server/test with test user test at server and
after that everything worked.

So the correct procedure seems to first create a node
/home/server/user and then any /home/server/user/nodes

(Perhaps I don't remember well but before it was possible to create
directly nodes under /home/sever/ without specifying a user)

-- 
Fabio Forno,
Bluendo srl http://www.bluendo.com
jabber id: ff at jabber.bluendo.com


More information about the ejabberd mailing list