[ejabberd] ejabberd 2.1.3, jwchat and mod_http_fileserver cannot deal with UTF-8 user names

Badlop badlop at gmail.com
Wed Apr 14 18:01:07 MSD 2010


2010/3/24 fulan Peng <fulanpeng at gmail.com>:
> Change mod_http_fileserver to Apache, still the same problem
> iJab can login but it cannot display and it cannot register.
>
> Any body know any web based client can handle UTF-8 user names such as Chinese?

I tried ejabberd 2.1.3 with http_bind and mod_http_fileserver
* JWChat failed to login to account 中文@localhost
* JWChat failed to login to account tám at localhost
* JWChat login correctly to account tam at localhost

I got an alpha build of OneTeam [1], configured it to use HTTP-Bind,
and it can login to all three accounts.
For example, when it logins to the 中文 account, the ejabberd log file shows
it works correctly (even if displays the username strangely):

=INFO REPORT==== 14-Apr-2010::15:24:42 ===
I(<0.517.0>:ejabberd_c2s:708) : ({socket_state,ejabberd_http_bind,
{http_bind,<0.516.0>,{{127,0,0,1},44220}},ejabberd_http_bind})
Accepted authentication for 中æ by ejabberd_auth_internal

=INFO REPORT==== 14-Apr-2010::15:24:43 ===
I(<0.517.0>:ejabberd_c2s:831) : ({socket_state,ejabberd_http_bind,
{http_bind,<0.516.0>,{{127,0,0,1},44220}},ejabberd_http_bind})
Opened session for 中æ@localhost/OneTeam


See a screenshot:
http://tkabber.jabber.ru/files/badlop/oneteam-translators.jpg

So, the problem doesn't seem in HTTP-Bind code:
maybe in JWChat, or in ejabberd HTTP code.



[1] http://www.process-one.net/en/blogs/article/oneteam_xmpp_client_entering_private_alpha/

---
Badlop
ProcessOne


More information about the ejabberd mailing list