[ejabberd] mod_echo working 50% of the time.

Kirk Bateman kirk.bateman at gmail.com
Tue Feb 16 18:18:03 MSK 2010


Sounds like two issues...

Issue 1, google talk from what I remember doesn't like routing stanzas to
any jid which isn't in your contacts, so that can be a problem (although
testing has previously shown that this is not ALWAYS the case, sometimes it
is perfectly happy).

Issue 2, why are you trying to run the mod_echo on the main domain of the
server (mydomain.com) ? as it is a component it would make more sense to run
it on something like echo.mydomain.com, so your message would get sent to
test at echo.mydomain.com

Just my thoughts.

Cheers

Kirk


On 16 February 2010 14:57, Conor Hunt
<conor.hunt+ejabberd at gmail.com<conor.hunt%2Bejabberd at gmail.com>
> wrote:

> I'm trying to use the mod_echo module on my server, like this:
>
> {loglevel, 4}.
> {hosts, ["mydomain.com"]}.
> {listen,
>  [
>  {5269, ejabberd_s2s_in, [
>    {shaper, s2s_shaper},
>    {max_stanza_size, 131072}
> ]}
> {s2s_default_policy, allow}.
> {shaper, fast, {maxrate, 50000}}.
> {access, s2s_shaper, [{fast, all}]}.
> {modules,
>  [
>  {mod_echo, [{host, "mydomain.com"}]}
>  ]}.
>
> I then send a message to test at mydomain.com from google talk and it works
> fine
> about 50% of the time. I get the message echoed back. The other 50% of the
> time
> it fails to route the message to mod_echo. Here is the log of that at level
> 5:
>
> http://gist.github.com/305568
>
> Anyone able to tell me what I am doing wrong?
>
> Thanks.
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20100216/f6944ea6/attachment.html>


More information about the ejabberd mailing list