[ejabberd] ejabberdctl update error (was Re: mod_admin_extra compile option - where to put code, includes)

Daniel Dormont dan at greywallsoftware.com
Sat Apr 2 00:04:18 MSD 2011


Ah, thanks. When I tried it via the web admin, at least in the case of the specific module I was trying to modify (mod_muc_admin) it didn't seem to take. That is, it looked like the previous version of the code was still being called from my testing (of the web admin UI itself). I hadn't realized the "update" command was meant to reload/restart modules. I tried it just now though and got this:


=INFO REPORT==== 1-Apr-2011::15:56:25 ===
D(<4838.11946.0>:ejabberd_commands:314) : Executing command ejabberd_admin:update with Args=["mod_muc_admin"]
** at node ejabberd at danslaptop **
Problem 'error {badmatch,false}' occurred executing the command.
Stacktrace: [{ejabberd_update,get_current_version,1},
             {ejabberd_update,'-get_updated_beams/1-fun-0-',1},
             {lists,'-filter/2-lc$^0/1-0-',2},
             {ejabberd_update,update_info,2},
             {ejabberd_update,update,1},
             {ejabberd_admin,update_module,1},
             {ejabberd_ctl,call_command,3},
             {ejabberd_ctl,try_call_command,3}]

Whereas, running l(mod_muc_admin) from the debug window worked fine.

cheers
dan

On Apr 1, 2011, at 3:20 PM, Badlop wrote:

> 2011/3/30 Daniel Dormont <dan at greywallsoftware.com>:
>> in a separate terminal running ejabberdctl debug, I do
>> 
>>> l(mod_muc_admin).
>> 
>> and this works fine. But if I could replace the latter with a simple ejabberdctl command,
>> that would be swell.
> 
> 
> When you overwrite beam files, you can update them in the running
> ejabberd node using the WebAdmin, or:
> $ ejabberdctl update_list
> $ ejabberdctl update mod_admin_extra
> Updated: []
> 
> 
> ---
> Badlop
> ProcessOne
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd



More information about the ejabberd mailing list