[ejabberd] xml-not-well-formed error

George Catalin Serbanut cgsmcmlxxv at gmail.com
Mon Aug 15 13:27:02 MSD 2011


I suppose you used the bot (or something similar) from the example

http://www.process-one.net/en/blogs/article/scalable_xmpp_bots_with_erlang_and_exmpp_part_iii

correct? Then, you have the supervisor of that gen_server implemented as
external service and not the supervisor from exmpp. Also, the guards should
be implemented before you create the packet to be sent by exmpp.

Cheers,
CGS




On Mon, Aug 15, 2011 at 11:15 AM, Alexander Kuleshov <kuleshovmail at gmail.com
> wrote:

> Hello,  thank's for reply.
>
>
> >I think without presenting a record of the suspicious TCP session
> >(captured by tcpdump for instance)
>
> Tcpdump i attached.
>
> >To solve that problem, either set a guard for the messages size and speed,
>
> Where can i do it?
>
> >increase the restart rate in your supervisor
>
> Is this exmpp_sup?:
>
>   %% XML.
>    XML = {xml,
>           {exmpp_xml, start_link, []},
>           transient,
>           10000,
>           worker,
>           [exmpp_xml]
>          },
>
> Or it's not from exmpp?
>
> Thank you.
>
> _______________________________________________
> ejabberd mailing list
> ejabberd at jabber.ru
> http://lists.jabber.ru/mailman/listinfo/ejabberd
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20110815/b66fc7e1/attachment-0001.html>


More information about the ejabberd mailing list