[ejabberd] ejabberd 2.1.5-34 (Debian squeeze) not allowing me to set up a "group ignore"

Phil Reynolds phil-jabber at tinsleyviaduct.com
Sun Feb 13 21:56:08 MSK 2011


I set up ejabbberd 2.1.5-3 on a new server today - I already had one  
running it but that was probably installed at an earlier version and  
upgraded with time.

On the old one, I had set up a group ignore, as this XML console output shows:

<iq from="emleymoor at hallam.tinsleyviaduct.com" type="result"  
to="emleymoor at hallam.tinsleyviaduct.com/Lounge" id="getlist2">
   <query xmlns="jabber:iq:privacy">
     <list name="ignore-group">
       <item action="deny" order="0" type="group" value="Ignore"/>
     </list>
   </query>
</iq>

However, when I do this on the new one:

<iq>
   <query xmlns='jabber:iq:privacy'>
     <list name='ignore-group'>
       <item
           type='group'
           value='Ignore'
           action='deny'
           order='0'/>
     </list>
   </query>
</iq>

... it fails, thus:

<iq from="emleymoor at firthpark.tinsleyviaduct.com" type="error"  
xml:lang="en" to="emleymoor at firthpark.tinsleyviaduct.com/Lounge">
   <query xmlns="jabber:iq:privacy">
     <list name="ignore-group">
       <item action="deny" order="0" type="group" value="Ignore"/>
     </list>
   </query>
<error type="modify" code="400">
<bad-request xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/>
</error>
</iq>

Am I going about this the wrong way or have I encountered a real problem?

Thanks in advance for any help.

-- 
Phil Reynolds
email: phil-jabber at tinsleyviaduct.com
Jabber: emleymoor at firthpark.tinsleyviaduct.com

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.



More information about the ejabberd mailing list