[ejabberd] muc und 404 remote-server-not-found

David Mohr damailings at mcbf.net
Wed Jan 26 19:54:45 MSK 2011


On Wed, 26 Jan 2011 13:48:27 +0100, David Mohr <damailings at mcbf.net>
wrote:
> Hi,
> I'm running an ejabberd server which has the main purpose of hosting
> a muc. I'm using mod_muc.
> 
> I don't have a lot of participants but every now and then people get
> kicked out of the room with the following message:
>  USER left the room (This participant is kicked from the room because
> he sent an error presence: remote-server-not-found).
> 
> I turned on debug logging but wasn't really able to identify the
> source of the problem.
> 
> This happens very frequently with one participant, who is also
> running his own ejabberd server. He is running ejabberd version 2.1.6,
> while I'm running 2.1.5-2~bpo50+1 (debian lenny).
> 
> Does anyone have suggestions on how to debug this? I'm a bit at a loss...

After a more recent disconnect we were able to find interesting log
entries:


MUC SERVER (say conference.foo.de):

=INFO REPORT==== 2011-01-26 14:11:23 ===
I(<0.7981.0>:ejabberd_s2s_out:235) : s2s connection: conference.foo.de
-> bar.de (stopped in open socket)

=INFO REPORT==== 2011-01-26 14:11:23 ===
D(<0.7981.0>:ejabberd_s2s_out:861) : terminated: {normal,open_socket}


OTHER SERVER (bar.de)
=INFO REPORT==== 2011-01-26 14:11:23 ===
D(<0.6998.0>:ejabberd_socket:178) : Error in gen_tcp:send:
{error,closed}


Any idea what could be causing this issue?

Thanks,
~David


More information about the ejabberd mailing list