[ejabberd] Ejabber S2S Help

Kirk Bateman kirk.bateman at gmail.com
Fri Jul 1 00:41:07 MSD 2011


Looks like your firewall isn't allowing the s2s incoming from external
servers.

A quick google will show a list of incoming ports required for federation.
Also, look at s2s dialback in the docs.

Also I didn't look at config, but you do have a proper domain setup for your
server right ? Not just localhost.

Hope that helps

Kirk
-----Original Message-----
From: Aamir Khan
Sent: 30/06/2011, 9:32 PM
To: ejabberd at jabber.ru
Subject: [ejabberd] Ejabber S2S Help

I want to setup Ejabberd chat server for private network. I have intranet
and i am running ejabberd server in one of the server in private network. I
have configured it to work perfectly on local network but now i want to
extend its functionality to be able to chat with gmail, facebook,
jabber.organd other friends. I started to make it work with
jabber.org first. When i add some new friend somefriend at jabber.org to my
private network jabber id and tries to debug, it says *Received XML on
stream = " "*.

I am using {loglevel, 5}.  and *netstat -taupen | grep 5269* shows a
ESTABLISHED connection with 208.68.163.220:5269 which is indeed IP address
of jabber.org. So the connection with jabber.org is established but i am not
getting any response from the remote server.


Here is my ejabberd.cfg : http://pastebin.com/AXyCj9e3

Here is relevant entries in ejabberd.log : http://pastebin.com/ruZj38Uv


-- 
Aamir Khan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20110630/9ce22eac/attachment.html>


More information about the ejabberd mailing list