[ejabberd] Mod_multicast service-unavailable

Jorge Díaz jorgedf at gmail.com
Sun May 1 00:59:49 MSD 2011


Hi everyone.

I've spent some days trying to make this module work
http://www.ejabberd.im/mod_multicast

I've downloaded, compiled, placed in the proper directory, and then
configure it in

# /etc/ejabberd/ejabberd.cfg
>
> {mod_multicast, [
>
>      {host, "multicast.dev.triviapad.com"},
>
>      {access, multicast, [{allow, all}]}
> ]}


And everything seems to work fine when i restart the ejabberd daemon.
But when i query the server asking for multicast service

<iq from='xmppadm at dev.triviapad.com' id='001' to='
> multicast.dev.triviapad.com' type='get' xmlns='jabber:client'>
>   <query xmlns='http://jabber.org/protocol/disco#info'/>
> </iq>


I always get a service-unavailable.

<iq from='multicast.dev.triviapad.com' to='
> xmppadm at dev.triviapad.com/26505952551304146854634511' id='001'
> type='error' xml:lang='en' xmlns='jabber:client'>
>   <query xmlns='http://jabber.org/protocol/disco#info'/>
>   <error code='503' type='cancel'>
>     <service-unavailable xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/>
>   </error>
> </iq>



Any one can tell me how should i check if the module is properly loaded and
working?

Thanks in advance to all.
Jorge

-- 
*Jorge Díaz*
email: jorgedf at gmail.com
spain: +34 620829213
us: +1 (415) 309-8039
chile: +56 (9) 87038661
skype: xurdedf
about.me/xurde
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.jabber.ru/pipermail/ejabberd/attachments/20110430/d21a4fcf/attachment.html>


More information about the ejabberd mailing list